Sometimes, you may want to flash a MikroTik with Minim, but instead of truck-rolling to the customer's home and grabbing the router to flash using the traditional method. This will explain how to install Minim on an individual router over SSH.
If you would like to do a bulk migration, please contact support@minim.com for assistance.
Requirements for initial provisioning:
- You MUST have SSH access or equivalent and add ether1 MAC address to inventory.
- SSH port must be open and set to port 22
- API port must be open and set to 8728
If you use an obscure SSH port you may enter the following into the bottom script (be sure to add your port number)
/ip firewall nat add comment="Minim SSH Access" chain=dstnat action=dst-nat protocol=tcp dst-port=22 to-port=CHANGEME src-address=10.0.4.0/22
The first step once you have successfully logged into the MikroTik.
(Default login is "ssh admin@xxx.xxx.xxx.xxx")
1. Copy this script. or visit our Github to always be up to date on our provisioning scripts.
/user add group=full name=autoconf password=autoconf address=10.0.0.0/8,172.16.0.0/12 comment="Minim Setup User"
/ip route add check-gateway=ping distance=1 dst-address=10.0.4.0/22 gateway=10.3.0.1 comment="Minim API Gateway"
/interface sstp-client add connect-to=tikvpn.minim.co disabled=yes name=Minim-setup-VPN password=autoconf profile=default-encryption user=autoconf_minim comment="Minim setup VPN"
/ip firewall filter add chain=input action=accept in-interface=Minim-setup-VPN place-before=1 comment="Trust traffic from Minim-setup-VPN"
/interface sstp-client set disabled=no [ find where name=Minim-setup-VPN ]
2. The output should look like this (once you Paste, you should not have to hit enter)

3. Then type, if the unit does not come online within a couple minutes.
/system reboot
4. Once your device has come back online you should see it in Minim!
Comments
0 comments
Please sign in to leave a comment.